免费分享
个人遇到的疑难问题

ffmpeg4之yasm一键编译安装shell脚本

腾讯云1折

大家好,近期我会给大家一系列关于ffmpeg拉流推流装置的安装,这个东西需要安装很多的东西,现在我们从最关键的组件yasm开始吧,当然,如果你在编译的过程中遇到的麻烦,或是因为不理解造成编译失败,又着急用的话,可以使用文章后边提供的yasm一键安装脚本。

PS:如果你对此文章比较头大,可以使用文章尾部海豚提供的一键安装脚本,轻松解决你的痛苦!

yasm海豚作一个简单的介绍,这个组件呢主要是为ffmpeg编译提供类似加速的功能,实际上是可以不用安装的,但这里我们还是讲解一下yasm的安装方法

yasm目前的最新版本是1.3.0,首先我们把yasm1.3.0wget下来:

wget http://www.tortall.net/projects/yasm/releases/yasm-1.3.0.tar.gz

可以看到下载下来的是tar.gz包,这里我们使用tar命令进行解压

tar -xzf yasm-1.3.0.tar.gz

然后进入到yasm文件夹

cd yasm-1.3.0

接着我们就可以./configure yasm了

sed -i 's#) ytasm.*#)#' Makefile.in &&
./configure --prefix=/usr &&
make && make install

这里有条命令解释一下,sed -i ‘ s#) ytasm.*#)#’ Makefile.in,这条命令是让防止vsyasm和ytasm的编译,这两个东西是运用于Windows的,在linux的centos下不适用

编译yasm过程中可能会出现以下错误:

configure: error: in `/opt/yasm-1.3.0':
configure: error: no acceptable C compiler found in $PATH

关于这个问题,是因为没有安装Gcc和Gcc-C++的原因,本来ffmpeg4.0是基于Gcc6.3.0以上版本的,但由于安装编译Gcc时间太过长,所以这里提供一个比较简单的处理方式,就是通过yum库安装,虽然版本有点低,但还是可以用的啦!

yum -y install gcc gcc-g++

ubuntu安装gcc和g++的方法

apt-get -y install gcc-4.8

apt-get -y install g++-4.8

最后,有的人的电脑或VPS是比较浪的,连wget、tar、make都没有,所以大家执行下面的命令安装完就可以了

yum -y install wget tar make

看到上图即表示安装成功!

下面是一键安装脚本,一条命令即可成功安装yasm,针对懒人相当有效!

yasm-1.3.0【一键编译安装脚本】

yum -y install wget && wget -O yasm1.3.0.sh https://cae.letogther.cn/shell/sh/yasm1.3.0.sh && sh yasm1.3.0.sh
赞(0) 打赏
转载本文请注明出处:一同学习 » ffmpeg4之yasm一键编译安装shell脚本

心情好就赏一波!

支付宝扫一扫打赏

微信扫一扫打赏